Twitter timeline limited to 140 characters?

When using the Twitter Timeline node, I am only able to get the first 140 characters of each tweet. How can I retrieve the full 280 characters? Thanks.

1 Like

Hello @loginjrr -

I am able to reproduce this problem as well. The odd thing is that some tweets are truncated, but others do in fact have > 140 chars… and it’s not clear why this inconsistency is happening. I’ll update the ticket we have in our system for this issue, and see if we can figure out what’s going on.

Thanks for reporting this!


Hi @loginjrr

As I look into this more, it appears that only retweets that are being truncated at 140 characters. Is this consistent with what you see?

Looking at the Twitter API, it seems the node isn’t utilizing the extended mode introduced here:

I think the KNIME node should add the tweet_mode=extended parameter to the query.

Hi @loginjrr -

I think this has already been implemented on our end, at least partially - perhaps not for retweets though, as I mentioned above. Thanks for the feedback, I’ll see if one of our developers can take a closer look.

Hello again @loginjrr -

The devs have addressed this problem, and retweets no longer are truncated at 140 characters. The fix should go out with the next release of KNIME Analytics Platform. In the meantime, if you’d like, you can download a nightly build ( and verify that this is working properly.

Thanks again for bringing this issue to our attention.

1 Like