Type from String to Integer


I´m a beginner with KNIME, I have a csv file and in one of the columns I have the sales, I use the Node CSV reader and when the file is in KNIME the sales column has a Type String, then I use the node From String to Number, but it´s not working. In the Console I get this error. The 52,04 is the value of the first row

Values in 403 cells could not be parsed, first error: ’ 52,04’ (RowKey: Row1, Position: 2)

Any idea how I can I fix this ?

Thank you !

Hi @Jax and welcome to the KNIME community forum,

In the configurations of the String to Number node set comma “,” as “Decimal separator”.

If you have Thousands separator, set it as well.


1 Like

You can can use File Reader instead. It has column type configuration option on preview.

1 Like

Hi @armingrudd, thanks for your answer.

I have set the decimals to comma, but I still get the same error

Values in 645 cells could not be parsed, first error: ’ 52,04’ (RowKey: Row1, Position: 32)

Hi @izaychik63, Thank you for your reply,

If I use the File reader instead the the CSV reader the columns are not imported properly

Hi @Jax,
if you have numbers with decimal separator, you need to select “Number (double)” as type in order to allow for decimal numbers.
Kind regards


Set type to Number (double).


Thanks @AlexanderFillbrunn. It was that

Thank you @armingrudd. I change it to Number (double) and it works.

Thanks for your support !!

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.