Ubuntu: Problem getting KNIME installed


I recently switched from Win to Ubuntu.
So I’m in the wonderful situation to reinstall all (or at least most) previous installed software packages.
One of them is KNIME.
I did not find any installation package so I’ve downloaded the zipped archive knime_4.7.2.linux.gtk.x86_64.tar.gz
But after depacking it seems that the access rights are not correct.

Question 1: Did I miss the installation package for Linux (Ubuntu)?
Question 2: If I need to proceed with the downloaded package: What do I need to do to get KNIME up and running on Ubuntu?

Now I’m some some taps further.

I’ve found this thread Install KNIME on Linux (Ubuntu) here in the forum.
So I added the mentioned PATH extensions to the ~/.bashrc

export PATH=$PATH:“/home/$USER/bin/KNIME”

After granting execution rights to the file “knime” I can start it.

But it immediately throws an error.

JVM terminated. Exit code=13

I’ve identified that the path name contains two //.
The extended path in ~/.bash.rc does not end with /.

What do I make wrong?
Where’s the root cause of this?

Hi @knimediger, could you please tell me what version of ubuntu you’re using? Also, just out of curiosity, did you also try installing a different version (say, 4.7.1)? If so, did you also get this error?


1 Like


Thanks for responding.
At the moment I’ve installed Ubuntu 22.10 (and it’s asking for upgrading to 23.04).
No, I did neither download any elder version nor try to install it.
Being new to Linux I’m not to used to all the new features I’m getting now.

What I see with KNIME for Linux compared to Windows: There are two simple ways to install KNIME under Windows and both are working well. I’ve used both on several machines and it was a No-Brainer.
For Linux it seems to be more delicate but there is no real good documentation available (at least I was not yet able to find it).

Usually it works out of the box if you simply extract the tar.gz archive. There is no need to change any permissions. How did you unpack the archive?


I did use P7Zip - Desktop and unpacked the content of the archive to ~/bin/KNIME.
In there I first adapted the knime.ini and then I tried to open the file knime. That file was not executable. So I changed the permission of knime to executable.
From the other thread I learned that I have to adjust $PATH as mentioned above.

Your question made me thinking and I tried the standard Archive Manager in Ubuntu to unpack the archive.
Worked as expected and KNIME started without problems.

There is only a start-up message that tells that I’m using Wayland and this might cause some problems.
What does this mean?
What can I do?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.