Version compatibility

I faced an interesting issue today. I created a workflow in my Mac KNIME IDE. I exported a knwf file, moved it to a linux machine and executed it in a BATCH mode. The invocation failed and I got a message:

ERROR main BatchExecutor Unsupported workflow version: Unable to load workflow, it was created with a future version of KNIME (4.1.0.v201912201424). You are running 4.1.0.v201912041250.

So, both instances are the same major, minor and even micro version from a common versioning strategy point-of-view and they differ just in build numbers or rather time the build was assembled and even though there’s no back compatibility? If so, it makes a team collaboration pretty complicated.

Just additional info. I downloaded the version I run on my Linux machine two days ago from the URL This was definitely considerable time later then I installed KNIME Analytics Platform to my mac. I’m attaching a screenshot of the installation history from my Mac

I guess there’s no Linux edition compatible with the last Mac edition of KNIME Analytics Platform available at the time. Am I right?

Another question. Why does the KNIME on the Linux machine complain the workflow “was created with a future version of KNIME (4.1.0.v201912201424)”? I created the workflow from scratch today. As you can see in the picture I provided in my previous post, the version on my Mac is KNIME Analytics Platform 4.1.0.v201912201454. I’m asking in order to get able to control my versions in the future. I know, there’s KNIME version propagated to XML files within a workflow but where is this value, the version number, taken from?

As a fast workaround, I modified the version in file workflow.knime.

First, I unzipped the KNWF file. I moved to the directory and ran:
[ders@ads-etl integration-test]$ sed -i s/4.1.0.v201912201424/4.1.0.v201912041250/ workflow.knime
Then I edited the shell script I invoke my workflow with so I replaced the workflowFile option with workflowDir one pointing to the directory the unzip command had created.

My workflow hasn’t finished successfully because of another issue so I don’t know whether the actions I took are sufficient or not.

Have both Mac and Linux versions both been updated to the latest versions? There was a bug fix pushed out in late December without a minor version increment, which looks like about the timestamp on your ‘future’ version. See this post:

for details.

1 Like

Hi @Vernalis
Thank you for your help.
I have my Mac KNIME updated. I haven’t updated my Linux version after I downloaded it three days ago. The explanation you’ve given seems to be the key.

Two questions:

  1. How can I update KNIME platform to a newer version, I guess it should be 4.1.0.v201912201424 in my case, in non-gui environment? To get my workflows working I already installed some extension in command line there using -application org.eclipse.equinox.p2.director command line option, could I use this way somehow?

  2. Should I expect this can happen and therefore I’m supposed to look for potential updates after I download fresh release from an URL like ? And if so, where can I check what is the last version to update to (I know, I can check my desktop KNIME AP but I wouldn’t consider it reliable enough).

Thank for your support,

I’ve tried this:

/knime/knime_4.1.0/knime -noSplash \
-application org.eclipse.equinox.p2.director \
-repository \
-installIU \
-destination /knime/knime_4.1.0 \
-profile KNIMEProfile
Installing 4.1.0.v201912201424.
Operation completed in 10576 ms.

It didn’t help. Still complaining about the version. Guess I need to update something else too.

Does it help to remove the version from the -installIU argument, i.e.:

-installIU \


Hi, Steve,
no, it didn’t help. It produced the same output the former attempt with the version provided did and the workflow failed again.

ERROR main BatchExecutor Unsupported workflow version: Unable to load workflow, it was created with a future version of KNIME (4.1.0.v201912201424). You are running 4.1.0.v201912041250.

Well, there must be a feature or bundle or whatever which KNIME compares the version of the IDE the workflow was made with and that whatever is obviously of version 4.1.0.v201912041250. Now the question is how to get that whatever upgraded?

Have you tried adding --launcher.suppressErrors as an option to the command as mentioned here -


Hi, @Vernalis,

thank you for the idea.

I haven’t tried it yet so I don’t confirm it really gets around the issue. But I believe it must work. All in all, in this case particular, I’d prefer getting the installation updated because of the December update brought a fix of an issue I need solved, see DB writer stops in the Loop

I like being able to update my Linux instance via the command line, without GUI. As a workaround, I could install and update the KNIME instance on another (virtual/Docker) Linux instance and transport it to the machine I plan to run it.

Thank you for your collaboration, I always appreciate it.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.