WebGL is not supported by your browser

#1

Hi there,

We have a few WebPortal models which enable the view of 3D Scatter plots which are created using the Generic Java Script View node (using plotly code).

These worked fine until recently where we started getting error messages and the scatter plot no longer shows on the WebPortal (we’re using Chrome as the web browser)

The error messages include:

image , and then:
image

We’ve tried some online suggestions to modify the Chrome settings (by enabling WebGL on Chrome) and to update video card drivers but these didn’t fix the problem. I noticed a post below that experienced issues when using WebGL via RDP, but not for the WebPortal…

Does anyone know of a solution to this?

Thanks!

Mike

0 Likes

#2

Hi @michazeidan -

Sorry for the trouble. Let me check with our server support folks and get back to you.

You said this was working before… did you make any recent changes to your server installation - upgrading from 3.7, for example? Or anything else that might coincide with this error?

0 Likes

#3

Hi Scott,

Thanks for getting back to me.

Yes, we upgraded the Server to 4.8 (from 4.6 I believe). The new installation was made on a new physical server with new supporting apps etc. The current verison of Chrome which we use on this new server is Version 77.

Thanks again,

Mike

0 Likes

#4

Hi @michazeidan -

Thanks for the additional details on your upgrade to a new server - that’s helpful. Are there any warning or error messages in the KNIME log that appear around the execution of the Generic Javascript View node? If you have the log and could send it, that would be great.

I’m doing a bit of digging on this end too.

0 Likes

#5

So, when you visit https://get.webgl.org/ with your web browser - outside of KNIME - do you see the spinning cube, or still get the error message?

If so, you might try reinstalling Chrome from scratch - or install a different web browser and test that, if possible.

One of our developers did some internal testing on this, and was unable to reproduce the problem from our side.

0 Likes

#6

Hi Scott,

When trying to access the website from Chrome that is installed on the same server on which the KNIME server is installed I get an error:

,

So it might be a starting point to get this to work properly first before trying something else - i’ll see if our IT can reinstall it. If this doesn’t work i’ll send the KNIME Log Files - i’d rather not place these on the forum can you please provide an email to send these to?

Thanks,

Mike

0 Likes

#7

At this point it seems almost certain to be a browser issue rather than a KNIME issue… but if sending the log files becomes necessary, you can always direct those to support@knime.com.

Keep us posted!

0 Likes

#8

Hi Scott, I’ve done some further investigation with the help of our IT group:

Changing the Chrome settings via Settings->Advanced->System and disabling the ‘Use hardware acceleration when available’ solves the WebGL problem and allows the 3D visualisation to be viewed as required.

However…we have so far not been able to make that setting ‘stick’ on the web-browser that the Knime-Server uses! We have tried changing the user-settings, enforcing the change on the server via:

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Google\Chrome]
"HardwareAccelerationModeEnabled"=dword:00000000

But this didn’t work. We also tried to change the KNIME Preference page to use Internet explorer, and tried both the ‘use internal browser’ option and the ‘use external browser’ options. All these settings seem to be getting ignored and KNIME always uses Chrome to open the visualisation.

On further investigation the Chrome that KNIME uses isn’t the Chrome version that we installed on the server, but a different, older version of Chrome that must have been installed within the KNIME app installation…? Whatever we do it it reverts back to opening its own chrome installation and we can’t figure out how the change this or at least find where that installation lives and change its settings…Any suggestions?
(sorry for the long post…)

0 Likes

#9

Mike,

Just making sure where you set the browser prefs in KNIME: Preferences -> KNIME -> JavaScript Views, or Preferences -> General -> Web Browser? Should be the former for visualizations.

Cheers,
Roland

0 Likes

#10

Hi Roland,

Thanks for clarifying! we were using the latter! Changing the former enables us to see the 3D visualisation when in the Knime Desktop application, but still no joy for viewing in on the WebPortal.

See below for our JS Views preference setings:
image

We’ve tried other settings that also don’t work. Note that out Chrome application is v77 and the settings above suggest that Knime supports V69-71 so should we try to install an older version?

Thanks,

Mike

0 Likes