Webportal Parameters in URL

Hi Team,

I am using knime server version 4.14.2 and would like to set some parameters in Webportal Workflows with URL parameters.

I tried following this link Webportal Parameters in URL and set up the below web portal link:

https://workflow location in server/ToolChangeWarning_Visualisation?exec&pm:filedir-445=file directory,filename-451=2022-11-15T18-20-36.235_698156.csv

Parameters are passed as below in web portal and the workflow fails:

When i directly execute the workflow in web portal without any parameters, It executes successfully.

Could you please let me know the correct way to pass the parametets in URL for knime server version 4.14.2.

Thanks,
Raj

Hello @rajvenkatesh_k ,

which configuration node(s) are you trying to configure over URL parameters?
Also are you sure the URL what you are trying to use is correctly formatted? (No ‘space’ character is in it, or the ‘file directory’ parameter value is formatted correctly? I guess you need the absolute knime:// protocol path, but only guessing.)

Best

Hello @dora_gcs ,

I am using string configuration nodes to pass file directory and file name over URL parameters. I also checked that there are no spaces in the URL and config parameter names.
In the workflow, we are trying to read files from ADLS2 and visualize data using scatter plot. I wanted to make file path and file name dynamic using URL parameters. I didnot understand your comment on where to use the absolute protocal path.

Please find the attached workflow on how we named parameters in string config nodes.

ToolChangeWarning_Visualisation_test.knwf (18.6 KB)

Output from the webportal is below:

Thanks,
Raj

Hi Raj,
Have you tried using the Create File/Folder Variables node? It has an optional file system input port so you can easily create paths for a particular connection.
Kind regards,
Alexander