Welcome Screen Loading wait times

Hi,
When Starting the Knime Platform, I see lagging loading items especially Png photos for the welcome screen. I guess it can be solved by using a lower resolution photo for the welcome screen feeds.
it would be nice to shave a good 3 min load time just for the photo download :slight_smile:

Thanks for all the hard work you put in. Knime Team ROCKS! :slight_smile:

1 Like

Hello @Safak,

starting KNIME lasts 3 minutes? If so maybe antivirus program is to blame? FAQ | KNIME

Additionally you can try starting KNIME with -clean and see if it helps:

Br,
Ivan

1 Like

Hi Ivan,
Thanks for Quick Reply.
İn Knime 3.7 I faced a similar issue with Antivirus and it’s been resolved by then. This is a completely new issue and surfaces from time to time when the Welcome screen changes.


I wait for these 3 images to be downloaded during the start-up phase.
and the main screen stays unresponsive like this;

My Connection is Fiber 35 Mbits/s and no other download ( İncluding Knime Example server) is slow.
My guess is that all over the world Knime Startups are pulling the same 3 pictures might overwhelm the server especially when the png size is huge ( I cannot give an MB value since I can’t see where the file is downloaded)
I hope this helps to spot the root cause.
Regards,
Safak

1 Like

By the way, I put
-clean parameter
on Knime.ini, run it and deleted the parameter as you’ve suggested. it helped a bit ( like a minute shaved off) but it still waits for downloading the Png files longer than it should be.

1 Like

Hello @Safak,

can you check your antivirus program one more time? Version 3.7. was some time ago so might be you need to do it again. Also, considering you have fast connection and no one else is experiencing the same I would rule out it’s due to downloading images. Still might be something related to images cause of what you said.

Br,
Ivan

1 Like

Hi @Safak , I would lean towards the antivirus too. Can you try to open these images from a browser and see the behaviour there?

Alternatively, if you don’t need the welcome page, you can also disable it.

I would remove the welcome screen but maybe I am missing something here

Hi,
@ipazin, Virus Exclusion is on;

@bruno29a, How can we disable welcome screen?

I’ve found how to disable welcome Screen. Thanks :slight_smile: ;

2 Likes

Hello @Safak,

glad you found a way. May I know how long loading takes without welcome page? Possibly it’s due to firewall. Let’s see if someone else experiences similar issues.

Br,
Ivan

1 Like

Hi Ivan,
Skipping Welcome Screen was a bad idea. İt took longer than I thought.
I’ve reverted back to welcome Screen.
Just Upgraded from 4.3. to 4.3.4 ( Avoiding Latest and Greatest 4.4 for now)
It shaved from 2.14 to 0.47 until the welcome screen. That’s a big move.
After Welcome Screen lands, From 0:47 to 2:16 I’m still waiting for pictures to download;
image

I’m not behind a Firewall, (working from home) yet, Company VPN might be a similar cause.
2.16 is when the VPN is off and fresh windows restart.
I’ll try with my personal computer and report back here.
By the way. 2:16 is totally acceptable for me despite a good chunk of it is on Welcome Screen.
Thanks for your knd help.

1 Like

Hello @Safak,

Glad to hear that.

Ok. Let’s keep in touch and see.

Br,
Ivan

If you disable the welcome screen and make sure that you first loading screen is an empty workflow you should be faster
br

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.