Window Node

If I use the Window Node I get the Error "unable to connect to renderer"

Any idea what produces this Error?

Which version of the Selenium Nodes, which browser, which operating system are you using?

I use the newest Selenium Version 3.4, but with older versions I get the same error since today. 

With Chrome on Windows 10

Thanks, can confirm the issue now -- obviously happens after the most recent Chrome update.

I'll investigate this and keep you posted here.

Please try the following:

  1. Download ChromeDriver 2.33 binary for your OS from here: https://sites.google.com/a/chromium.org/chromedriver/
  2. Unzip the file
  3. Go to Preferences -> KNIME -> Selenium and select the downloaded ChromeDriver in “Path to ChromeDriver”

Does this solve your issue?

Yeah it helps.

Thanks

fyi: This is solved in Selenium Nodes v2.0.1 -- no more manual configuration necessary.

Hi qqilihq,

A little OT but I am suffering the same problem

The interactive view cannot be opened for the following reason:
unknown error: call function result missing ‘value’
(Session info: chrome=65.0.3325.162)
(Driver info: chromedriver=2.29.461585 (0be2cd95f834e9ee7c46bcc7cf405b483f5ae83b),platform=Mac OS X 10.13.3 x86_64)

I have installed the 2.36 chromedriver in
17:22 $ which chromedriver
/usr/local/bin/chromedriver

But I do not have any Selenium preferences to set?! i.e. I cannot tell KNIME to look for the right drivers to another location.

Any help please?

Hi there,

But I do not have any Selenium preferences to set?! i.e. I cannot tell KNIME to look for the right drivers to another location.

That’s weird. Could you please post or send me a screenshot of your KNIME preferences window?

Thanks,
Philipp

Thanks Philipp,

I attach a screenshot of the prefs window.

prefs knime 3.5.2

Cheers

Thanks.

Which version of the Selenium Nodes are you running? Can you check the version in the “About” dialog under “Installation details”? The most recent one is 2.0.2? Did you ever see the “Selenium” preference screen, or where did you enter the license key?

Dear Philipp,

I have installed now the selenium nodes 2.0.2 and can now configure the chromedriver PATH in the settings, and replicate successfully the ‘search results scraping’ example from the seleniumnodes site.

However, I still have problems with other workflows, such using Generic Javascript View nodes, as the same error is thrown, i.e. driver 2.29 is used.

Is there a way to configure all KNIME nodes (not only the selenium nodes) to use a specific chromedriver path?

Thanks

Hi AlfredoLupo,

apologies, I think I understand your issue just now.

You’re talking about KNIME’s Interactive View nodes, not about the Selenium nodes. I’ve missed that in your initial message. The JS view nodes technically use Selenium as well, but they’re entirely separate from the nodes in the “Selenium” section. That means, that changing any setting for the Selenium nodes will not have any impact on the View nodes.

I’d recommend opening a bug report in the general KNIME forum section, as the View nodes are maintained by KNIME themselves.

Sorry for the confusion.

Best,
Philipp

I am experiencing the same problem(s) when trying to open js previews; please see my screen cap in link:

Thanks Philipp and longoka,

I will keep digging

Cheers