Can’t install extensions or update KNIME after updating to 4.6 - No repository found

I am not able to install new extensions or check for updates to KNIME. I get the same error:
‘Contacting Sofware Sites’ has encountered a problem.
No repository found at
Same thing happens when trying to update KNIME
Please let me know if you’re seeing the same error and if you have a fix - thanks!


I’m also experiencing this issue.

Same here. Yesterday it was working like a charm, and today I’ve tried to open another workflow with some KNIME extensions (not community ones), and it does not work.

Hi @Mirri, @edwar_forero and @rpereira
Thank you for reporting this issue, we added a new extension to the partner update site yesterday, which might have caused this temporary disruption. Can you try restarting your AP and try updating again?


1 Like

Hello Gabriel,

I restarted my AP and also my PC, and even tried in another KNIME and PC, still getting the same error message:
Thanks for the quick response!

Hi @edwar_forero thank you for your patience and trying this out, I am very sorry that this is currently not working as expected, while we work on a fix I can offer you the following workaround:
In your KNIME AP preferences you can disable the Partner Update site, as shown in this screenshot, this will allow you to install extensions from other update sites:



Hello Gabriel. The solution you suggested worked! Thanks!

Sorry, Gabriel, could you tell me how to install the KNIME Personal Productivity Tools and KNIME Hub Connectivity Extensions? These extensions are not in the software sites. Thanks!
Pd. We’re working under KNIME AP 4.6.2

Hi @edwar_forero,

  • KNIME Hub Connectivity Extension is only available for 4.7
  • Personal Productivity is available from the default update site:


I am also experiencing this issue, on KNIME 4.7 on both Windows and MacOS on my personal PC’s (no KNIME server).


Hi @edwar_forero, @DrewG42, @rpereira, @Mirri

We found a solution for this problem, affected users can trigger a manual refresh of the update site from their preferences, which should fix the issue:
To do so select the partner update site and then click on the “Reload” button:



Great work! Thanks, Gabriel.

A post was split to a new topic: Community Extension Installation Problem

Is it possible to make this post sticky somewhere or create a PSA? The forum posts about this keep coming and I suspect a lot of users will encounter it eventually.

(ping @ScottF)


Good idea - I just made a pinned post for this purpose. :+1:

1 Like

I have experienced this issue while checking updates and installation of extensions too.

I follow instuction, but it’s still doesn’t work, can help?

Dear all,

I am still unable to install KNIME extention after trying the solution by Gabriel.
Could you please help on this issue?