Change standard decimal separator

Hello,

 

how can I change the standard decimal seperator from '.' to ',' in KNIME?

Output is not correctly recognized in excel, changing my language settings to english is no solution for me.

 

Thanks for your help.

Hey,

the '.' is just the standard decimal seperator in KNIME and as far as I know there is no option to change this. So if you want to export your data to EXCEL, an easy workaround would be using the Number to String node and a String Manipulation node afterwards. For the latter you use the replace function and simply exchange all '.' with ','. Hope that helps.

Cheers,
Marten

For completeness, I'll also post this here:

There's a convenient way to format data in the node output tables called "Renderers". They can be set by right-clicking on the column header. You can also set default values, e.g. a format for variables of type double, via File > Preferences > KNIME > Preferred Renderers > Basic > Number (double) 

Unfortunately, there is no Renderer that uses the comma (",") as the decimal separator. I have adressed this to the KNIME support and they promised to look into it.


Of couse, as a workaround, you can also export any node's output using the regular way: Connect the node table output to a Excel Writer node. The Excel Writer apparently recognizes your systems locale settings and formats the Excel files accordingly. It's less convenient than just copy-pasting node output to Excel, but it works for now.

2 Likes

It’s two years later (june 2019) and still it is not possible to use a ", " as a decimal separator. They seem not very interested in this basic problem.

You could do this with a Java Snippet node with a few lines of code that uses the DecimalFormat class.

2 Likes

Hi there,

ticket has been open for this and your request noted.

Br,
Ivan

2 Likes

Hey,

Has this issue/ticket been solved yet?

Cheers,
Patrick

Sadly no. You can export numerical values correctly using excel writer node, but not just copying-pasting into excel.

Luca

Hello there!

request(s) noted (Internal reference: AP-12121)

Welcome to KNIME Community @pcropalato!

Br,
Ivan

Hi!
Would love to know if there is any progress on that point?
Yes, I know all the workaround, I just feel there should be a formating for all the countries that use the EU number format system (nothing against the US ^^).
Many thanks!
Dimitri

1 Like

Hello @dimi,

and welcome to KNIME Community!

No progress for now but added +1 in above mentioned ticket.

Br,
Ivan

2 Likes

hey, i’m new using Knime but as a brazillian i also needed to change the decimal separator.

I did it by using the CSV Writer, in advanced settings.

hope this helps future users.

BR
Yuri.

1 Like

Help us in Brazil. We use “,” how decimal!!!