Editor initialization failed: org.knime.workbench.editor.WorkflowEditor. Site is incorrect

Hi all,

I am very new to knime. I am having troubles running an already working workflow. I was able to load the project in KNIME. But when I came back on the same project I could not load the workflow anymore. Below is the error I am getting.

Editor initialization failed: org.knime.workbench.editor.WorkflowEditor. Site is incorrect

Error images are under this link

https://drive.google.com/drive/folders/1fu4jOO-AWNUJsuuWnERemsWs1R8_Tc5T?usp=sharing

I would really appreciate some help from the community.

Hello @tma,

welcome to KNIME Community!

What KNIME version are you using? Have you ever successfully ran this workflow on your own?

Br,
Ivan

Hi Ivan,

Thanks for your response.

Yes I was able to run the workflow before. Then I imported another workflow, it gave me the error mentioned above. I installed some Java Lab extensions, it worked but later both the workflows showed the same error. I don’t know what is wrong exactly.

I am using KNIME 4.2.1.

Best
Tma

Hello @tma,

see this topic as same error message is given to another user.

Can you share your KNIME log?

Br,
Ivan

From the screenshots it might have to do with the DL4J community extension

https://www.knime.com/deeplearning4j

Do you use or need that extension? I think I saw problems with that earlier. It would not load correctly. If you do not use it can you uninstall it?

1 Like

I get this annoying error rather often now when trying to open existing workflows:

Only fix: Restart KNIME.

fwiw: I do not have any “Lab” or DL4J nodes installed.

Hey there,

I have had a look at this and there will be a fix coming up that should address this issue.

At least for the scenario I considered, this is indeed not related to any extensions.

A deterministic way to reproduce this error is as follows:

  1. Open a workflow and edit it

  2. Begin closing the AP by exiting the application (e.g. on Windows by pressing the red X in the title bar)

  3. When prompted whether to save the modified workflow, click “Cancel”.

  4. Expected: the AP should remain open, the workflow is not saved and other workflows can be opened without problems.

  5. Problematic: Opening a new workflow causes the error message shown above.

@qqilihq Could this be the issue in your case? It would exceptionally nice if you’d grab a nightly build and verify that everything works as expected there.

Best Regards,
Ben

2 Likes