Empty results / 429 status using WebDriver on hotel website

I am trying to run this website (https://www.hyatt.com/ ) on the WebDriver, but once it’s run, I get an empty page + 429 status on Chrome.

I assume the issue is bot detection (the site uses Kasada and maybe others too) and I have tried the various different snippets available in the WebDriver settings but all result in the same empty page.

Any ideas on how I can get around this? I am not trying to do anything “en masse” - I’m iterating through a small number of searches/pages so it’s not like I am bombarding the site with requests.

Any ideas on how to get around this?

It looks like fgsantos has tried similar and got some suggestions from qqilihq a couple of years ago. I tried these but it’s still giving the same result.

Did you check:

Thanks - yes I did check that post and a couple of other related discussions. I got the same results when using the Chrome for Testing (bundled, undetected) BETA setting.

Anything else you can suggest?

Thanks for your assistance.

Can you share your workflow, reduced to the essentials?

Certainly - https://file.io/42qbh2aOgrXt.


Thank you!

I just tried this locally and I can successfully circumvent the 409 error, display and interact with the webpage using the techniques described here. Please have a close look at the instructions given there, it will require some more steps than just selecting the “Undetected” WebDriver.

If you require additional input, feel free to get in touch at mail@seleniumnodes.com