Half screen problem (50% grey)

I’ve seen and tried to apply the recommended solution for the Windows / Half Screen bug using version 4.2.3, (which is to change workspace i believe)… but the fixes listed haven’t helped. Any other ideas?

1 Like

Hello @msweetnam,

is this from a fresh installation or after you have done update? Or after you installed some extension?

Have you tried starting KNIME with -clean parameter? Have you maybe tried reinstalling it?

Check this topic:

Br
Ivan

Bumping this because I’m having the same issue with a fresh install of 4.2.3 on both Windows and Mac.

1 Like

Thanks @ipazin… I tried working through the solution for the “Windows / Half Screen bug using version 4.2.3, (which is to change workspace” and it worked. Not sure what I did the first time, but this time it worked.

1 Like

Hello,

glad you fixed it @msweetnam.

Did you manage to get full screen @aidanschneider?

Br,
Ivan

Hi,

I have the same problem on Mac Big Sur and KNIME 4.3.0 .
Reinstall does not solve it, swapping workspace works only until I close KNIME (i.e. switching to a new workspace solves the problem momentarily. If I close KNIME and reopen it, it has the grey area again. Switching to a new workspace works again until restarting KNIME).

Can you help me pls. this is way more than annoying.

Hi @snooby and welcome to the forum.

Sorry for the delayed response here. Have you tried deleting the workbench.xmi file as described in the thread below?

Very sorry for the trouble. This is a bug we’re actively working on.

1 Like

Hi Scott,

Thanks for the reply. When I swapped to a new workspace I deleted the entire old workspace folder (implicitly the workbench.xmi in it, I suppose).
In the meantime I abandoned KNIME for the project as I couldn’t really use it, so the troubleshooting got less urgent for me. However, I am happy to help you trying out solution options :slight_smile:

Hi @snooby

I’ve figure it out how to fix this problem permanently on windows 10 and Knime 4.3.1:
0.5)at first,you should start a new workbench save and close the Knime(like the same thing you did before).

1)go to your KNIME installation folder
2)right click on knime.exe and open properties
3)under Compatibility tab set compatibility mode to windows 7(Maybe knime has problem with windows 10)
4)check the disable fullscreen optimization and run this program as administrator

5)(optional)if you’ve Knime on you’re laptop i suggest you to check the override high DPI scaling behavior by Application(click on change high DPI setting);for even more clarity and quality.

good luck :wink:

Hi @Nishef,
Thanks for the suggestion, unfortunately I am using Mac.
I am happy that it works for you :slight_smile:

Hello there,

just to drop info that with version 4.3.2. this is addressed and half screen problem shouldn’t happen any more. (AP-16147)

If workspace already has this issue and is opened with 4.3.2 for the first time a simple restart will fix it.

Br,
Ivan

2 Likes

The same problem happens with 4.4, and the same fix fixes it (i.e. change workspace)
Can you guys put the appropriate fix in prior to the next release?