How to avoid the crash: "Keybinding conflicts occurred. They may interfere with normal accelerator operation."

I have such problem with workflow execution spontaneously: in different parts of workflow at difrent loop iterations. After the crash I just Reset the previous (to those with crash warning) node and Execute it again. Everything works, but I need manual interventions.
PS. I checked forum posts on the topic: no information transfer by network during my workflow execution, only local calculations.

Hi @Alex_Vilnius and welcome to the forum. This is a strange one - do you have handy a log file from when this error occurs? If so, can you post it so I can relay to someone on our development team?

1 Like

Hello Scott, thank you for answer. I exported the log file and uploaded it.Log1.log (547.0 KB)

Thanks for the log. I’m asking internally - let me see what I can find out.

Do you also have a workflow that reliably demonstrates the problem? That would help as well - if the data is non-confidential, that is.

1 Like

I need to ask permission, I deal with my university students data.

Hi Scott, any progress on troubleshooting this? I’m having the same problem/error message using a Rank node. I can’t figure out how to upload my workflow to show you just the section I want to show you… How can I make the data table that feeds it be stagnant? Meaning not connected to the rest of the workflow.

The Rank node is using a flow variable called “Column Name” as the Ranking Columns


Use Table Writer on data output port you feed to Rank node. Then create new workflow which will feature Table Reader node and Rank node and hopefully produce this error so it can be checked. If needed create flow variable holding column name as well.

See here how to share reproducible workflow examples where you include data within workflow and use workflow relative paths:


1 Like

Thank you Ivan, I have now attached the workflow in question. What I’m trying to do is a loop as suggested to me in this other topic

The error occurs in the Rank node and the keybinding error is seen in the error log but when you hover over the red “x” on the Rank node it says: Execute failed: Length of arguments vary: 1 vs 0

RankNodeError_Keybinding Conflict.knwf (36.6 KB)

Thank you for any help,


Can you attach some dummy data to go along with the workflow, please?

Hi Scott, that’s what I asked earlier. How do I import a table without it being linked to one of my network drives? Sorry, still learning…


See Ivan’s response above about how you can include data files within your workflow. In the meantime, it would be helpful if you could a sample file directly to the forum (assuming it’s not business confidential) so that we can troubleshoot the error message you’re seeing.

Thanks Scott, I’m still confused. I did do exactly what Ivan suggested. When I look at the Table Reader I see the data but I suspect you don’t because it’s path is an internal network drive at my office here. How do I get around that? And I thought I had uploaded the workflow above…? I see it. I just dragged it over…


Ah, I think I see the problem. When you export the workflow, by default there is a option checked for “Reset Workflow(s) before export”. This resets the workflow, meaning we can’t see it in its executed state like you can. So, you can either export the workflow NOT reset, or you can upload your Excel data for us to load ourselves.

Does that make sense?

Yes! Thank you for your patience and clarifying. I’ve uploaded again here without reset.RankNodeError_Keybinding Conflict2.knwf (62.5 KB)


I think the problem is that in your Rank node, you’re trying to overwrite a column name, but there doesn’t yet exist a column in the dialog to overwrite.

I went into the dialog and clicked the Add button (it doesn’t matter which column is added - it gets overwritten) and now the rest of the workflow seems to work OK:

Can you try that?

I know it’s a bit counterintuitive. One of the quirks of working with flow variables, I’m afraid. :slight_smile:

1 Like

Hi Scott, thank you! Ok, I got that to work but it only worked for the first column. The loop only created one ranked column and stopped there (it ranked column “Origin#2684”). I need the loop to rank each column with the name like Origin#*. If you see in this other thread, Rank each column by value ignoring blanks. In there @esamuel built the solution -although with a simplified mock table of data instead of using a variable.

Also I will need that new rank column to have the name of the column it ranked in the column title. Is there a way to do this with a Math Multi Column node?


Does this give the result you’re looking for?

RankNodeError_Keybinding Conflict_SF.knwf (70.6 KB)


Yes! Yes! Yes! Thank you so much! I’ve been struggling with this one for days. I really appreciate your help.



This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.