issue in CLI knime - Application "org.knime.product.KNIME_BATCH_APPLICATION" could not be found

Hi All,

i’m trying to get Knime to run in batch mode, but i get the following issue

java.lang.RuntimeException: Application “org.knime.product.KNIME_BATCH_APPLICATION​” could not be

i’m following the instructions from this page by running the linux command

/mnt/windows/Users/Admin/Projects/bin/knime_3.7.1-linux/knime -nosplash -application org.knime.product.KNIME_BATCH_APPLICATION​

i know i’m in a bit of a strange setup, but i run the linux binary from a windows NTFS partition… there’s currently no other way.

i can run Knime from that same location in GUI mode without any issue!

i checked the following topics, but i believe the don’t apply here




cfr attachment1557591218787.log (3.3 KB)

any ideas ?

Herman

It’s strange as even the log says that org.knime.product.KNIME_BATCH_APPLICATION is a known available application. Does it change anything if you cd into /mnt/windows/Users/Admin/Projects/bin/knime_3.7.1-linux/ and then run it from there?

1 Like

Hi Quaeler,

thx for your reply!

it gave me the same issue initially, then i just deleted the last character of the command and re-wrote it… SOLVED!

so it seems the copy-paste is really sensitive…
hermy@kali:/mnt/windows/Users/Admin/Projects/bin/knime_3.7.1-linux$ ./knime -nosplash -application org.knime.product.KNIME_BATCH_APPLICATION
CompilerOracle: exclude javax/swing/text/GlyphView.getBreakSpot
May 11, 2019 6:11:52 PM org.apache.cxf.bus.osgi.CXFExtensionBundleListener addExtensions

Usage: The following options are available:
-nosave => do not save the workflow after execution has finished
-reset => reset workflow prior to execution
-failonloaderror => don’t execute if there are errors during workflow loading
-updateLinks => update metanode links to latest version

2 Likes

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.