Knime explorer: Deleting workflow group


I noticed that deleting workflow group in Knime explorer doesn’t work as expected. The workflow group disappears when I delete it (by pressing the right mouse button and delete) but It comes back after closing Knime and restarting. I use KNIME 4.1.0 (windows version).

Best regards,


Hi @mustanaami0,
welcome to the KNIME forum! A workflow group corresponds to a folder in your KNIME workspace. I suspect that when you click “Delete”, the folder is not really deleted in your file system, maybe due to a permission problem? Does it work correctly when you start KNIME as administrator? Or does your workspace lie on some shared file system? Can you check if the folder is gone after you clicked “Delete”? Maybe your KNIME log file (View -> Open KNIME log) is worth checking out. Do you find any error at the bottom after you have tried deleting a workflow group?
Kind regards

Hi Alexander,

I am using the Knime with administrator account. The knime-workspace-folder is in the local drive. No error messages concerning this issue is shown in the Knime.log file. When I delete the workflowgroup, the workflowgroup-folder disappears from the knime-workspace folder. But when I shutdown the Knime the same workgroup-folder comes back. That is quite strange.

I managed to get rid of the useless workflowgroup-folders by removing them with windows explorer. Now they are gone forever.

BR, Petri

1 Like

See here:

Had the same problems back then, unsure whether they got it fixed in the meantime. I worked around it by creating a new workspace (simply deleting the empty directories didn’t help afair.)


I’m experiencing the same problem today.
I hope it could be fixed soon.


A post was split to a new topic: CRTL+F accelerator issue

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.