KNIME Takes Long to Load?

Hi all,

I notice that it sometimes takes 4-5 minutes for KNIME to load up. I’ve added all of the “Additional Nodes” suggested on the welcome screen and dedicated 11 of 16gb of RAM to KNIME.

Are the additional nodes causing it to load slowly? If so, how can I remove nodes packages that I don’t use (e.g. H2O, etc.)?

Below is the splash screen from initial loading of KNIME showing some of the node packages loading.

image

Thank you.

Hi @Haystack,

adding more Additional nodes (we call them extensions) causes your KNIME to load slower (similar to how more addons in your browser cause it to start up slower). I would only install the extensions that you need.

You can uninstall by going to the the toolbar and click Help > About KNIME AP > Installation Details. Select all the extensions you don’t need and click the Uninstall button at the bottom of the dialog.

Some extensions are installed by default and I would advise to keep them. Here is a screenshot of all extensions in a minimal KNIME 3.6.2 installation.

I hope that helped.
Cheers,
Johannes

3 Likes

Thank you, @johannes.schweig!

-Haystack

You might want to check your virus scanner. On certain systems with quite aggressive virus scanners I experienced KNIME to be slow. Since it can contain several 1,000 single files an ‘agressive’ virus scanner might scan all of them every time they are accessed/opened. When we changed the settings KNIME started faster. Of course there is a trade off between security and speed. But modern virus scanners might be able to have a flexible configuration.

But of course the number of AddOns and the overall performance of the machine also play a part. Considering overall performance you might want to have a look at this thread:

If you want to have great models I would encourage you to keep the H2O.ai nodes though :slight_smile:

6 Likes

Thank you for the information, @mlauber71.

After removing several extensions, I got the load time down to < 1 minute. I kept the H2O.ai nodes, however :wink:

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.