Unable to launch KNIME AP from Eclipse

I wan’t to develop a KNIME node. In order to do that I followed the setup-sdk manual (https://github.com/knime/knime-sdk-setup). Here is what I’ve done and which versions I’ve installed:

  • I installed java 8 (my execution environment is JavaSE-1.8 (jre1.80_241)
  • I installed Eclipse for RCP and RAP Developers (version 2020-03 (4.15.0)
  • I cloned the setup-sdk repository (https://github.com/knime/knime-sdk-setup) and use the lateset release branch (2019-12) as suggested on the forum (SDK Installation - Branch Selection)
  • I set KNIME-AP-complete.target as active target
  • I run the application using Run on “KNIME Analytics Platform.launch”

This worked. KNIME AP was started without any errors.

Then I need to install the KNIME Node Wizard using this description (https://docs.knime.org/latest/analytics_platform_new_node_quickstart_guide/index.html#_create_a_new_knime_extension_project).

If I then launch KNIME AP again as I’ve done before, I get the following error message in Eclipse:

!SESSION 2020-05-28 09:48:50.123 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_241
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_GB
Framework arguments: -product org.knime.product.KNIME_PRODUCT
Command-line arguments: -product org.knime.product.KNIME_PRODUCT -data C:\Users\ashwet\eclipse-workspace/…/runtime-KNIME -dev file:C:/Users/ashwet/eclipse-workspace/.metadata/.plugins/org.eclipse.pde.core/KNIME Analytics Platform/dev.properties -os win32 -ws win32 -arch x86_64 -consoleLog

!ENTRY org.eclipse.equinox.app 0 0 2020-05-28 09:48:52.139
!MESSAGE Product org.knime.product.KNIME_PRODUCT could not be found.

!ENTRY org.eclipse.osgi 4 0 2020-05-28 09:48:54.564
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: No application id has been found.
at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:242)
at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:657)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:594)
at org.eclipse.equinox.launcher.Main.run(Main.java:1447)
at org.eclipse.equinox.launcher.Main.main(Main.java:1420)
An error has occurred. See the log file
C:\Users\ashwet\runtime-KNIME.metadata.log.

I’ve also tried to install the KNIME Node Wizard as follows:

  • Open (Double click on) KNIME-AP-Complete.target
  • Locations -> Add -> KNIME Node Wizard -> Install

That didn’t change the problem.

Then I’ve searched on the forum for solutions and tried the following suggestions. None worked.

  • Cannot launch KNIME Analytics Platform from Eclipse. The Run-Configuration Plug-ins was set to “All workspace and enabled target plug-ins”. Which I believe is correct? Also, the option “Clear the configuration area before launching” didn’t help.
  • Someone told me that it may be that I am missing OSGi related components. So I installed them: Help -> Install New Software -> “The Eclipse Project Updates - http://download.eclipse.org/eclipse/updates/4.15” -> Search for OSGi -> Install “API Tools Execution ENvironment Descriptions” and “Equinox Target Components”. That didnt help either.

Hopefully someone knows what is wrong in my installation? Perhaps a wrong version?

1 Like

Hi @ashgard,

Can you make sure the target platform is still set? Eclipse has the unfortunate tendencies to regularly forget the target platform. To remedy this, open the target platform and click reload.

best,
Gabriel

Hi @gab1one

Thanks for your suggestion. Ive clicked the reload button a couple of times. Unfortunately that didnt change anything.

Does this mean my procedure is good?

If you have any other suggestions please let me know.

Thanks

Hi Ashgard,

It seems like the problem is caused by the node wizard,
you do not need it after generating the plugin so you could try just uninstalling it.

best,
Gabriel

Hi Gabriel

That seems correct. When I install everything without the Node Wizard, it works fine. After installing the Node Wizard the errors occur. I’ve tried different version of KNIME of eclipse and of Java. None seem to make a difference.

My main problem now is that I cannot use the manual to create a new node as described on here https://docs.knime.com/2019-06/analytics_platform_new_node_quickstart_guide/index.html. Below figure 4 is mentioned that the newly created node project should be visible in the package explorer of eclipse. But I dont see that. But perhaps there is anything else that can cause this?

Thanks, Ashgard

@ashgard

Do you have run as product in the run configuration correctly set?

@Mark_Ortmann
I think I have the correct configuration. I followed all instructions from https://github.com/knime/knime-sdk-setup. But if you can share the correct configuration with me (perhaps with a screenshot) then i can validate it

Do you have
Run a product checked and set to org.knime.product.KNIME_PRODUCT ?

@Mark_Ortmann: Yes I have that set.

My execution environment is JavaSE-1.8 (jdk-8.0.252.09-hotspot). Suppose that is correct?

Can it be something with the workspace data? I dont know how Eclipse should know that a new node project is created when I create one using the New Node Wizard of KNIME, but I suppose that it has something to do with correct workspaces? I didn’t change anything, so my workspace location is “${workspace_loc}/…/runtime-KNIME”

Thanks A

Hi @ashgard,

could you try uninstalling the node wizard and installing it again using the latest version? (using this update site http://update.knime.com/analytics-platform/4.2/). This worked for me. Maybe there is version mismatch in your case. To start KNIME from eclipse you can just right click on the KNIME Analytics Platform.launch file and select Run As -> Knime Analytics Platform. This should automatically use the right configuration for starting KNIME.

Cheers,
David

Hi @DaveK
Thanks for your reply. It didn’t seem to solve the problem. But I have to admit I have been trying out some things, so it could be I broke it.
What versions are you using which is working for you? I refer to the versions of:

Btw, I also tried on a fresh Linux installation, but I was getting errors too. It must be something I am doing wrong…

Hi @ashgard,

I just tried again on the release branch (2019-12) of the knime-sdk and this update site: https://update.knime.com/analytics-platform/4.1, which worked fine (generally, the version of the sdk branch should match the version of the update site. E.g. 2019-12 corresponds to 4.1. When I recommended using the 4.2 update site I was missing that you are not on the master branch). Which version of Eclipse are you using? I am using Eclipse IDE for RCP and RAP Developers Version: 2019-12 (4.14.0).

Hi @DaveK

Thanks for your reply.

Meanwhile i’ve tried a couple of combinations, but no success:

  • Eclipse IDE for RCP and RAP Developers (version 2020-03 (4.15.0) and Eclipse IDE for Java development (2019-06, version 4.12, got this version recommended by a collegue).
  • knime sdk release versions 2019-12, 2019-06 and the master branch.
  • I have used the knime update site that came with the knime sdk, I didnt change the versions.
  • I have tried KNIME-AP.target and KNIME -AP-complete.target
  • I have also tried the complete procedure on a Linux computer. On both computer I had the same problem. The main problem is that the knime packages (eg org.knime ) are not recognized, so coding is not possible, and the new knime node package is not published in the project explorer of eclipse (again coding is not possible). I think that the validation errors Im having can be ignored(?)

This means the target platform is not loaded correctly. You should try reloading it.
Regarding locating the newly created project, you might need to import it from your hard drive, alternatively you can just import the demo projects from https://github.com/knime/knime-examples and use those as a starting point, they are what you would get from the wizzard.

best,
Gabriel

@gab1one

You mean: when I double click on the target (eg KNIME-AP-complete.target), then I can first click on “set as active target” and then the text changes to “Reload target platform”. You mean the latter button, correct? I’ve clicked on it several times. Also after restarting eclipse of the computer. Is there something I can do to force it?

I will try to import the newly created as you suggested.

Thanks for your advice

Hi @gab1one

You were right. I had to click several times on Reload Target. I’ve done that before, but perhaps only(?) about 4-5 times. I now clicked it a lot more, perhaps 10-20 times, and got it working. I didn’t expect it would be necessary to reload it this amount of times. But it fixed the problem.

I’ve also been able to import my created nodes. I am now able to develop nodes.

Thanks a lot for your help!

1 Like

Actually you should not have to do this several times. Sometimes closing eclipse after reloading, clicking update whatever resolves this issue, but don’t know the exact combination to get it work.

Glad to hear that everything works now

Best
Mark

Hi @ashgard,

when opening the target platform, eclipse needs some time to resolve it first (especially on first load, this can take a long time). However, eclipse runs this task in the background. The UI only shows the progress in the lower right corner of the eclipse window, which is easy to miss. Did you wait until eclipse indicated that it finished resolving the target platform? If not this could explain why you had to click the button several times, i.e. giving eclipse time to resolve the target platform.

Cheers
David

2 Likes

@DaveK

Indeed I waited for the progress bar to finish. Something I noticed over there is that when the progress bar disappeared (finished) there remained an icon in the lower right corner (directly next to the progress bar). I forgot how it looked like, but I remember that it went away after I clicked Reload Target Platform several times. Not sure if it can be related, but once the icon was gone, everything worked fine.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.