Views: Configuration Dialog and Interactive views empty in 5.3

After installing 5.3, view nodes from the Views group in the node repository have an empty Configuration Dialog and show an empty interactive view when executed. This happens in both existing Workflows and new ones.

Statistics views from the Analytics node repository group seem to work fine.

I have both an upgraded Knime installation (from 5.2) and a new install. It happens for both. I’ve also tried using a new workspace. Still doesn’t work.

This is on Windows 11.

Is there some settings/configuration file I need to clear? What could cause this?

My Configuration Dialog components are still working, but my JavaScript interactive views are empty as well

Yes, I’m seeing that for the JavaScript views. Configuration Dialog is working for them but not the interactive view.

Widgets are also not working, neither configuration, nor interactive view.

Correction:

For widgets only the interactive views are not working. Configuration dialog is fine.

This error is appearing in the log when I attempt to show an interactive view for the Statistics View node:

!ENTRY org.eclipse.ui 4 0 2024-07-10 10:34:08.953
!MESSAGE Unhandled event loop exception
!STACK 0
java.lang.NullPointerException: Cannot invoke “org.knime.gateway.impl.webui.service.events.SelectionEventBus.addSelectionEventListener(java.util.function.Consumer)” because “selectionEventBus” is null
at org.knime.gateway.impl.webui.entity.UIExtensionEntityFactory.createInitialSelectionSupplierAndSetupEvents(UIExtensionEntityFactory.java:154)
at org.knime.gateway.impl.webui.entity.UIExtensionEntityFactory.createNodeViewEntAndSetupEvents(UIExtensionEntityFactory.java:100)
at org.knime.js.cef.pagebuilder.PageBuilderUtil$UIExtensionEnts.(PageBuilderUtil.java:344)
at org.knime.js.cef.pagebuilder.PageBuilderUtil.initializePageBuilderForView(PageBuilderUtil.java:124)
at org.knime.js.cef.nodeview.CEFNodeView.lambda$6(CEFNodeView.java:406)
at org.knime.js.cef.nodeview.CEFNodeView$3.completed(CEFNodeView.java:420)
at com.equo.chromium.swt.internal.Chromium.lambda$9(Chromium.java:870)
at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:40)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:132)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4047)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3663)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$5.run(PartRenderingEngine.java:1151)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:339)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1042)
at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:152)
at org.eclipse.ui.internal.Workbench.lambda$3(Workbench.java:639)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:339)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:546)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:173)
at org.knime.product.rcp.KNIMEApplication.start(KNIMEApplication.java:211)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:208)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:143)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:109)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:439)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:271)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.base/java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:651)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:588)
at org.eclipse.equinox.launcher.Main.run(Main.java:1459)

Thank you very much for reporting the issue so quickly!

It affects all node views and those node dialogs that have a node view preview; but ‘only’ in case the Analytics Platform has been directly started with the Classic UI (it remembers the UI it has been shutdown with).

We will publish a fix as soon as possible.

Till then you either use the Modern UI (it is not an issue there) or switch to the Modern UI and back again to make it work in the Classic UI, too.

5 Likes

Thanks for nailing this down. I’ve reverted to 5.2 for now, but may re-upgrade now since you found a workaround.