Knime Config Dialogs/Popups Blank

I am trying to edit some workflows on a remote linux machine (more accurately it's CentOS Linux Release 7.3.16111 (KDE 4.14.8))  - when I open any given node to either configure it or view the data output, it is currently displaying a blank screen like the one attached.

I have tried multiple workflows and I still cannot see the configuration window or data output of the nodes.

I am currently running Knime version 3.3.1. I have also attached my knime log which contains the logging for the output when I open a given node (which then displays blank).


That seems to be a difficult one. What type of remote display connection are you using and from which client (also linux, also KDE)? I wonder if you get the same screen artefakt if you use a real remote windowing system such as x2go or nxclient?!

Sorry, haven't come across this so far.


facing the same issue, have you found a solution?


Thank you 

just in case someone has the same issue:

I have a setup: 

Knimei installed on CentOS Linux Server where users are connecting with Xrdp 

problem was Xrdp->Xvnc

switching to Xrdp->Xorg 


solved the issue

Can you please elaborate this solution. I am facing the same issue but can’t solve it somehow. The Dialog box which opens up while configuring the node gives a blank screen.

1 Like

I have the same issue running Knime on Fedora 29. Althought I am not using remote desktop, I’m simply trying the run the software locally. Any ideas?

If you drag-resize the dialog, do you see it attempting to render the widgets?

Hello Quaeler,

I didn’t see any attempt to render the dialog when dragging nor resizing the dialog. In my case I solved the issue running the Windows build via Wine. That setup works perfectly.


Installing Fedora 29 locally in a VMWare Fusion instance and trying to run 3.7.2, i can confirm that there are a whole host of problems:

  • the blank file dialogs
  • opening an example workflow makes a no-title tab for the workflow editor and, all times except for once, a blank workflow editor
  • double clicking on a workflow editor expands to take over the whole KAP window as expected, but i’m unable to revert - and a “Reset Perspective” does nothing (reset followed by app relaunch did, though)

It’s unclear what versions of which Linux flavors and using which window managers are officially supported by KNIME.

F29 gave me GNOME - switching over to Cinnamon on Fedora 29 gave me a truly fugly, but functioning KNIME including the dialog panes… oh the fractured world of Linux :- /

1 Like

Same issue with Knime 4.0.0 on Ubuntu 18.04 LTS with Gnome. Super frustrating because it was my first time ever on Knime :frowning: … anyway, an easy solution on Ubuntu is to log out and log back in with a different desktop such as Gnome flashback, Gnome Metacity, Unity etc. There are a bunch of choices like that on the Ubuntu login screen

1 Like

I recently ran into this issue with a Centos 7.7 server, and @koma recommendation fixed the issue. Unfortunately they left out the “How” details, so here is how I did it.

First make sure xorg is installed

sudo yum install xorgxrdp

Then you will need to edit the xrdp.ini file

sudo vi /etc/xrdp/xrdp.ini

Now find the Xorg section near the bottom, and uncomment all the lines


Using a text editor, uncomment those lines to look like the following.

Restart the xrdp service, and now when you connect you can switch to Xorg


Then launch KNIME as normal with no additional environment variables.

This was only tested on Centos 7.7 with Xrdp from Windows 10 using default gnome and gnome-classic


I experience a very similar problem (Node dialogue empty or not opening), yet: I am not running it on a server, but a local machine with Opensuse Leap und Gnome.

However, I tried to fix it using the same approach as above. No success. Anyone still experiencing same problems? Any suggestions?


1 Like

I am having the same problem but its locally installed with Ubuntu

Did you by any chance figure out a solution?

The problem is still ongoing. As a very dirty solution I installed Knime via Wine and run it as windows emulation.

Anyone any solutions?


I still have not found the root cause, but I found a strange hint. Within Opensuse I can boot into different shells. If I switch from the standard Gnome into Gnome classics it magically works. I do not like Gnome classics as much, but at least it helps

Hi all,

I had the same issue in Gnome Manjaro and the way to fix it was in the discussion:

So, I executed on terminal:
export GDK_BACKEND=x11

and then, I went to the directory of the program and opened knime like this:

Now, I can see the Config Dialogs.